ANSYS CFX バッチチュートリアル

流体構造連成解析:CFX-Mechanical FSI

ここでは,Rescale 社の ScaleX プラットフォームで CFX と ANSYS Mechanical 間の流体構造連成(FSI)を実行する方法について説明します.CFXによるFSIジョブには、MFXソルバー(Multi-Field Run)を使用します。

この例では、振動するプレートを使っています。流体(空気)で満たされた閉じた空洞の底に、薄い板が固定されている。薄い板の片側に初期圧力100Paを0.5秒間かけて歪ませる。この圧力が解放されると、板は前後に振動して平衡を取り戻し、周囲の空気はこの振動を減衰させる。


このチュートリアルに従うために必要なファイルを入手するには、以下のジョブセットアップリンクをクリックし、ファイルをホストしているジョブをクローンします。次に、ジョブの Save をクリックして、Rescale のクラウドファイルにファイルのコピーを用意します。

入力ファイル

CFX と Mechanical 間で FSI 解析を行うには、以下の入力ファイルが必要です。

  • OscillatingPlate.def : CFX Input file
  • OscillatingPlate.inp : ANSYS Mechanical input file

これらの必要な入力ファイルの作成については、ANSYSのドキュメントを参照してください。


Rescaleジョブのセットアップ

必要なANSYS Fluentのファイルを入手したら、今度はRescaleでBasicジョブを投入します。Basicジョブの立ち上げについては、こちらのチュートリアルをご参照ください。

入力ファイル

  • Rescaleプラットフォーム上で、左上の「+New Job」をクリックします。ジョブに名前を付け、ジョブタイプがベーシックに設定されていることを確認します。
  • 次に、入力ファイル(.defと.inp)をアップロードします。ファイルがRescaleのクラウドストレージに保存されている場合は「クラウドストレージからファイルを使用」ボタンを、ファイルがローカルワークステーションにある場合は「このコンピュータからアップロード」ボタンのいずれかを使用します。
fsi new job.0518bdb8


ソフトウェアの設定

  • 次へ」をクリックして、セットアップの「ソフトウェア設定」セクションに進みます。Select SoftwareでANSYS CFXを検索し、ソフトウェアアイコンをクリックします。
fsi software.054836d9
  • Analysis Options]タブで、[Version]ドロップダウン・ボックスを使ってCFXのバージョンを選択できます。Command(コマンド)]で、CFX Multi-Field runに固有の以下のコマンドラインを入力します。
cfx5solve -def OscillatingPlate.def -ansys-input OscillatingPlate.inp -mfx-run-mode "Start ANSYS and CFX" -par-dist $HOSTLIST
fsi software setting.e9a1ad55
  • def フラグの後には CFX 入力ファイル(.def)が,-ansys-input フラグの後にはメカニカル入力ファイル(.inp)が続きます.mfx-run-mode “Start ANSYS and CFX” は,CFX ソルバーと ANSYS Mechanical ソルバーの両方を起動して Multi-Field ランを開始します.
  • ANSYS Mechanicalソルバーには、-ansys-argumentsフラグを使用して追加の引数を送信することができます。例:
cfx5solve -def OscillatingPlate.def -ansys-input OscillatingPlate.inp -mfx-run-mode "Start ANSYS and CFX" -ansys-argumenst "-np 4" -par-dist $HOSTLIST
  • 上記のコマンドラインでは,-ansys-argumenst「-np 4」によって,ANSYS Mechanical ソルバーに 4 つのパーティションを使用するよう指示しています.
  • ライセンスオプションで、適切なライセンスタイプを選択し、関連するすべてのフィールドにライセンスの詳細を入力します。

ハードウェアの設定

  • Hardware Settings で、適切なコアタイプとコア数を選択します。このチュートリアルでは、コアタイプとして Emerald を選択し、8 コアを要求します。プラットフォームページの右側に、ハードウェア情報の概要が表示されます。
fsi hardware.981f95db

レビュー

  • このチュートリアルでは、後処理に関する設定はありません。Reviewアイコンをクリックします。Basic Job Summaryテーブルを確認し、セットアップが正しいことを確認します。このように表示されるはずです。
fsi submit.a9b6a753
  • ジョブ設定を確認後、右上とジョブサマリーページにある青いSubmitアイコンをクリックすると、ジョブが送信されます。

ジョブモニタリング

  • ジョブを送信すると、プラットフォーム上にステータスページが開きます。ここでは、ガントチャートのような形式でジョブの進捗を監視し、日付と時間のスタンプ付きログを表示し、Live-tail ウィンドウを使用してジョブのステータスとアウトプットをLive-tailすることができます。Rescaleでステータスを監視する方法については、こちらをご覧ください。
fsi status.47eee467

また、RescaleのLive Tailing機能を使って、生成されたログファイルをクリックすると、実行の進捗状況を確認することができます。この例では、検索フィールドから.outファイルの検索をクリックし、以下のようにファイルの内容を表示することができます。

fsi livetailing.3d0b7408 1

CFD-Postでの結果のダウンロードと閲覧について

ジョブが完了したら、ローカルのワークステーションまたはRescaleデスクトップで結果を見ることができます。どちらの方法も以下に紹介します。

ローカルワークステーションで

注:大きな出力ファイルがある場合、WindowsユーザはRescale Transfer Manager(RTM)を使用して、オンプレミスのワークステーションにファイルを高速にダウンロードすることをお勧めします。RTMの詳細については、こちらを参照してください。LinuxまたはMacユーザは、Rescale CLIを使用して、より大きな出力ファイルをダウンロードすることができます。

  • 完了したジョブの結果ページに移動し、図のように「Download Job」アイコンを選択すると、すべての結果ファイルがダウンロードされます。特定のファイルのみをダウンロードしたい場合は、ファイルを選択して、「アクション」→「選択したファイルをダウンロード」をクリックします。Rescaleはすべての結果ファイルをZIPで圧縮します。
fsi download.11a0a04e
  • CFD-Postで結果を表示するには、アプリケーションを起動し、File > Load Results…をクリックします。結果ファイルを保存した場所に移動し、.resファイルを開くと結果が表示されます。

Rescaleデスクトップ上

ジョブが完了したら、以下の手順でRescaleデスクトップ上に結果を表示します。

デスクトップセッションを設定する。

  • 1.構成]ドロップダウンで、デスクトップセッションのハードウェアを選択します。
  • 2.Add Software」ドロップダウンで、「ANSYS Fluids Desktop」を選択します。バージョンを選択します(この例では、19.0を選択します)。
  • 3.ジョブ」ドロップダウンで、追加したいジョブの名前を入力したり、リストを参照したりして、ジョブを検索します。デスクトップにジョブを追加するには、「追加」をクリックします。
fsi desktop.f393a2fc

Desktopセッションが開始されたら、デスクトップ上のCFX Launcherアイコンをクリックし、CFD-Postを起動します。

fsi cfd post.d65aa221
  • CFD-Postで結果を見るには、アプリケーションを起動し、File > Load Results…をクリックします。Desktop > attached_jobs > [Job_Folder] > run1 と進み、.res ファイルを開いて結果を表示します。
fsi result file.d494e3d0