ANSYS Mechanical バッチのチュートリアル

このチュートリアルでは、ANSYS ジョブを Rescale プラットフォームにバッチで送信する方法を紹介します。 それぞれの ANSYS ソフトウェアから入力ファイルを作成し、再スケール ジョブを開始して送信し、結果を ANSYS に転送します。

前処理アクティビティ (ジオメトリ、メッシュ/モデルなど) はすでに完了しており、 セットアップ設定もすでに決定されています。 RSM を介したジョブ送信とは異なり、Rescale Desktops を起動する必要はありません。 独自の ANSYS ソフトウェアとライセンスを使用することも、当社に連絡して Elastic License Unit (ELU) を購入することもできます。

このチュートリアルでは、テーパー梁の静的構造解析に焦点を当てます。 ANSYS メカニカル 19.0 また、Rescale プラットフォームでバッチ ジョブとして実行を送信する方法を示します。 例 モデル は、長さ 15 フィートの鋼製のテーパー付き I ビームです。 大きい方の端で固定され、小さい方の端に 500 ポンドの力がかかります。
チュートリアル用の Workbench プロジェクト ファイル (.wbpz) を入手するには、 インポートワークベンチ 以下のプロジェクトのリンクをクリックして、 Save ジョブ送信ページの右上隅にあるオプションを使用して、このファイルのコピーを Rescale クラウド ファイルに保存します。

ワークベンチから入力ファイルを作成する

  • 入力ファイルを作成する前に、セットアップ前の前処理セルの状態が完了していること (緑色のチェック マーク) を確認してください。
  • 次の手順に従って入力ファイルを作成できます。すべての定義が完了したら、 セットアップ(A5)。 ANSYS Mechanical ウィンドウで、 解決策(A6) 左側のツリーの状態に移動し、 [ツール] > [入力ファイルの書き込み…]
  • プロンプトが表示されます。 「名前を付けて保存」 窓。 適切なファイル名とディレクトリを選択します。 この例では、input_batch.dat という名前を付けます。

ジョブの再スケール送信

  • Rescale プラットフォームに移動し、新しいジョブを開始して名前を付け、Workbench から生成した入力ファイルをアップロードします。 入力ファイルは、ローカル コンピューターまたは Rescale クラウド ファイルからアップロードできます。
  • この例では、Ansys Mechanical バージョン 19.0 を選択してソフトウェア設定を構成します。 基本的なジョブの起動の詳細については、チュートリアルを参照してください。 API).
  • コマンド ウィンドウで次のことを行う必要があります。 山括弧の下に入力ファイル名を指定します 。 このチュートリアルでは、コマンドは図の下で強調表示されているようになります。
  • ライセンス オプションを指定し、ハードウェア設定に進みます。 この例は 4 つの Emerald コアで実行されます。 ここには後処理オプションはありません。
  • ジョブを送信すると、ジョブのステータスを自由に監視し、ジョブに関する情報を入手できます。 リアルタイムで。 Rescaleの「モニタリングステータス」に関するガイドが見つかりました API).

結果を見る

ジョブが完了したら、ローカルで結果を表示できます。 または Rescale デスクトップ上で。 両方の方法を以下に示します。

ローカルワークステーション上で

ジョブが完了したら、ダウンロードするファイルを選択できます。

注: 大きな出力ファイルがある場合は、Windows ユーザーが使用することをお勧めします。 リスケール転送マネージャー (RTM) を使用すると、オンプレミスのワークステーションにファイルをより速くダウンロードできます。 RTM の詳細については、こちらをご覧ください。 API)。 LinuxまたはMacユーザーが使用できます CLI を再スケールする より大きな出力ファイルをダウンロードします。

  • ジョブ結果ページに移動し、 をクリックします。 Rescale Transfer Manager を使用してダウンロードする。 警告メッセージが表示された場合は、 Rescale.TransferClient.UI を開く
  • フォルダを参照 ウィンドウが開くので、ジョブ結果の保存先を選択し、「OK」をクリックします。 ダウンロードされ、ステータスが「完了」と表示されるまで待ちます。 ファイルは、ジョブにちなんで名付けられたフォルダーに保存されます。
  • ワークベンチに移動し、ハイライト表示します 解決策(A6) 左側のツリーの状態に移動し、 [ツール] > [結果ファイルの読み取り…]
  • An 開いた ウィンドウが表示されます。 前に指定したディレクトリを見つけます。 この例は Rescale Basic ジョブであり、出力ファイルは「run1」フォルダーの下にあります。 「file.rst」ファイルを選択し、「開く」をクリックします。 結果が ANSYS Mechanical に完全にロードされるまで待ちます。 これを確認する XNUMX つの方法は、ツリーと 解決策(A6) 状態が表示されるはずです 緑色のチェックマークが付いている

Rescale デスクトップ上

ジョブが完了したら、次の手順に従って Rescale デスクトップで結果を表示できます。

あなたのアップロード .wpbz ワークベンチ アーカイブ ファイルを Rescale Cloud にコピーします。 クリック ファイル と上 このコンピュータからアップロードする。 これによりウィンドウが開きます。 「.wpbz」ファイルがある場所に移動します。 ファイルをクリックして、 開いた

セットアップ デスクトップセッション:

  • 1.構成の選択 ドロップダウンで、使用するハードウェアを選択します デスクトップセッション
  • 2.ソフトウェアの追加 ドロップダウン、選択 ANSYS 構造デスクトップ
  • 3.仕事 ドロップダウンで、名前を入力するかリストを参照して、追加するジョブを検索します。 クリック Add デスクトップにジョブを追加するには
  • デスクトップセッションが開始されたら、起動します Ansys Workbench Rescaleデスクトップ上にあります
  • `.wpbz' ワークベンチ アーカイブ ファイルを次の場所からダウンロードします。 クラウド ファイルを再スケールする 以下のように – をクリックします クラウドファイル アイコンは Rescale デスクトップにあります。 [再スケール] ウィンドウで、 ファイル タブをクリックし、アーカイブされたワークベンチ ファイルの横にあるボックスをオンにします。 クリック アクション > 選択したファイルをダウンロード。 ファイルは次の場所にダウンロードされます。 ダウンロード Rescale デスクトップ上のディレクトリ
  • ANSYS Mechanical では、 をクリックしてプロジェクト アーカイブを復元できます。 フィレットアーカイブを復元する。 が保存されている場所に移動します。 .wpbz ファイルが見つかったのでクリックします。 この例では、次のように保存されます。 mech-batch-single-v19.wbpz
  • アウトラインツリーで、 解決策(A6) 左側のツリーの状態に移動し、 [ツール] > [結果ファイルの読み取り…]
  • 開いた ウィンドウで、前に指定したディレクトリを見つけます。 この例は Rescale Basic ジョブであり、出力ファイルは「run1」フォルダーの下にあります。 を選択 ファイル.rst ファイルとクリック 開いた 。 結果が ANSYS Mechanical に完全にロードされるまで待ちます。 これを確認する XNUMX つの方法は、ツリーと 解決策(A6) 状態は「緑色のチェックマーク」が表示されるはずです

重要: .rst および他のすべての結果ファイルが配置されているディレクトリを保存する必要があります。 そうしないと、ファイルが Workbench にロードされなくなる可能性があります。

この時点で、Ansys Mechanical 問題を解決した後に通常行うように後処理アクティビティに進むことができます。 ワークベンチ GUI で。

このセクションの焦点は、マルチフレーム解析のためのバッチ モードでの ANSYS Mechanical です。 場合によっては、分析が複数のシステムで構成される場合があります。 したがって、システムごとに入力ファイルを生成する必要があります。 この例では、前のセクションのテーパービームのソリューションが基本解析です。 固有値座屈解析を使用して、座屈時のビームの臨界荷重を見つけることに興味があります。 続行するには、システム B の XNUMX 番目の入力ファイルと、システム A からの再起動ファイルが必要です。マルチフレーム再起動と APDL の詳細については、ANSYS のドキュメントを参照してください。

ワークベンチプロジェクトのインポート
Import Job Setup
Get Job Results

ワークベンチから入力ファイルを作成する

  • マルチフレーム再起動の場合は、ワークベンチ上の XNUMX つのシステム間に必要な接続を作成し、前のセクションで示したように基本解析を解決します。 最初のシステムの実行が完了したら、次のように最初のシステムで結果ファイルを読み取ります。 前項 見出しの下に 結果の表示
  • すべての前処理セルのステータスが完了していること (緑色のチェック マーク) を確認してください。 さらに、XNUMX つのシステムが接続されていること、およびシステム A のソリューションがシステム B のセットアップに接続されていることを確認します。
  • ANSYS Mechanical を開き、次の項目を強調表示します。 溶液(B6) 代わりに XNUMX 番目の入力ファイルを書き込む状態になります。
  • 新しいジョブを開始し、この新しい入力ファイルをアップロードします。 この固有値座屈の例では、基本解析から .rnnn、.rdb、および .ldhi リスタート ファイルをアップロードする必要もあります。

ジョブの送信を再スケールする

ジョブ送信の残りのワークフローは前のセクションと同じです。 ジョブの送信後、結果を表示するために、更新されたジョブ ファイルを Rescale デスクトップに必ず含めてください。

結果の表示

アーカイブされたワークベンチ ファイルを Rescale クラウドにアップロードし、Rescale デスクトップにダウンロードします。 ワークベンチでアーカイブ ファイルを復元し、 溶液(B6) 新しい結果ファイルを読み取る状態。

この例のシミュレーションでは、負荷乗数 4.7012 が計算されました。 500 ポンドの力を加えたので、これは、 臨界座屈荷重は 2350.6 ポンドの力です。